Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am trying to install Wordpress on WAMP

I changed my localhost path to localhost:11245 in the WAMP config file, so when I load my apache admin screen I go to localhost:11245

When I loaded Wordpress, localhost:11245/wordpress, it prompted me to enter the admin information, that is what I entered :

  • Database Name : wordpress
  • User Name : wpadmin
  • Password : blank
  • Database Host : localhost:11245
  • Table prefix : wp_

When I click Submit, it loads indefinitely. Somehow I made it come up with the following error. I imagine this has something to do with me changing the port number.

Welcome to WordPress. Before getting started, we need some information on the database. You will need to know the following items before proceeding.

  • Database name
  • Database username
  • Database password
  • Database host
  • Table prefix (if you want to run more than one WordPress in a single database)

If for any reason this automatic file creation doesn't work, don't worry. All this does is fill in the database information to a configuration file. You may also simply open wp-config-sample.php in a text editor, fill in your information, and save it as wp-config.php.

In all likelihood, these items were supplied to you by your Web Host. If you do not have this information, then you will need to contact them before you can continue. If you’re all ready…

How can I get it to install?

EDIT

I was able to get WAMP to route to localhost, then I ran localhost/wordpress and went through the setup screen again with these settings :

  • Database Name : wordpress
  • User Name : root
  • Password : ``
  • Database Host : localhost
  • Table prefix : wp_

I just ran a php page with this info on it and it returned Connection OK

<?php 
$link = mysql_connect('localhost','root',''); 
if (!$link) { 
    die('Could not connect to MySQL: ' . mysql_error()); 
} 
echo 'Connection OK'; mysql_close($link); 
?> 
share|improve this question

1 Answer 1

up vote 1 down vote accepted

here are the instructions i followed:

http://webdesignerwall.com/tutorials/installing-wordpress-locally

share|improve this answer
    
I tried it with those instructions and I got a different error. Error establishing a database connection. Did you connect to http://localhost or did you have a port number like http://localhost:1232? –  guanome Jul 28 '11 at 20:13
1  
my sites are all localhost/folder_name where folder_name is the folder in my htdocs folder (i use xammp). db connection error means you need to ensure your db name, user name and password in wp_config.php match the values you created in phpmyadmin –  helgatheviking Jul 29 '11 at 1:16
    
I tried it with root userID and that seemed to work, I must have not set up my wordpress database userID properly. –  guanome Jul 29 '11 at 13:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.