WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have looked at the previous post here regarding a similar issue but what resolved them issues doesn't want to work for me.

Basically, I have a custom post type for football players for my home team, the slug for this post type is players and my permalink structure is /%category%/%postname%/ Now when I create a new player, and go to view the post, I get a 404, so I go to permalinks and click save. The custom post type of the player now works but with a strange issue, my pages now come back with a 404, post seem to work fine and aren't effected?

Now I am using a plugin called Easy Custom Content Types by Pippin, but this error also happend for me when using the Custom Post Type UI. I have tried different themes, deleting the .htaccess and nothing seems to work. The strange thing is that if I change the permalink structure back to default there is no issue, but I don't want that, I want to be able to use the permalink structure I'm currently using minus the errors.

So can anyone help to resolve this annoying error.


share|improve this question

closed as too localized by toscho Apr 16 '12 at 1:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

First thing to test would be to try with permalinks at default, and secondary using one of the provided structures, ie. non-custom. It's highly likely the problem is a result of your chosen permalink structure.. – t31os Jul 28 '11 at 13:51

Try this. Disable permalinks, then re-enable them.

share|improve this answer

i think it is probably the /%category%/ in your permalink structure.

share|improve this answer
No its not that, I have tried with simply /%postname%/ and that causes the same error. – Danny Jul 28 '11 at 14:59
can you post your code for registering your post type? – helgatheviking Jul 28 '11 at 19:50
Well I use a plugin but it has an export feature so you can import them into a fresh installation of Wordpress by adding this code to your functions.php file. So here is the code: pastebin.com/2PqMVd3d It's just very frustrating, I have spent hours disabling plugins, changing themes, deleting the .htaccess file numerous times and everytime it's the same thing. – Danny Jul 28 '11 at 20:03

You might also check for duplicate slugs/names.

If your post type has the same name (or slug or rewrite) as a category or page, it will wreak havoc with your permalinks and generate 404's. I just spent a day trying to figure this out on one of my own sites before I found the conflict.

Renaming the post type to something unique fixed it for me.

share|improve this answer
The slug name isn't the issue, as I only have 1 page and 1 post on my test site and there slugs are test and test2 – Danny Jul 28 '11 at 14:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.