Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I just definsed at Setting> Reading a page I have created called "home" as my homepage. The change was ok, but since them all my internal pages url shows an extra /home/in their urls.

How can I avoid it?

Examples:

Before: www.mydomain/internalpage/

After the change: www.mydomain*/home/*internalpage/

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

What @iampearce said is basically right, but to be a bit more specific: look in Settings > Pewrmalinks. Choose one of the defaults - maybe %year%/%postname% - and click Save. Does that help?

If that doesn't fix it, look in Settings > Reading and check that the "front page" and the "posts page" are not set to the same page via the dropdowns there. If you want your front page (home page) to be the blog page, just choose "Your Latest Posts".

Best of luck!

share|improve this answer
    
Many thanks! Finally, the issue was caused by a mistake. When I was trying to define my page called "home" as my site homepage, by mistake, I went to Settings/General/ and modified my "Site Address URL" to www.mysite.com/home. So, due that, all my site pages had added to their urls the /home/. Fixed it just correcting to www.mysite.com –  Adriana Aug 1 '11 at 17:56
add comment

Ensure it's not in your rewrite rules and specify a page to act as the posts page and it should go away. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.