Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Today I upgraded Wordpress to 3.2.1 and noticed that the nested list markup seems to be invalid.

This is the code it's producing:

<ul>
  <li>parent list item 1</li>
<ul>
  <li>child list item 1</li>
</ul>
  <li>parent list item 2</li>
</ul>

Instead it should look like this:

<ul>
  <li>parent list item 1
    <ul>
      <li>child list item 1</li>
    </ul>
  </li>
  <li>parent list item 2</li>
</ul>

Anybody else having this problem or have any idea what might be causing this?

share|improve this question
add comment

1 Answer 1

You have to uncheck "WordPress should correct invalidly nested XHTML automatically"

http://wordpress.org/support/topic/ordered-list-nesting-in-the-wysiwyg-editor

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.