Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using the Wordpress SEO by Yoast plugin. I'm having problems getting the Sitemaps XML section to work properly. Google gives me the dreaded red X for the status of the sitemap.

The error message Google gives is: 208 "Invalid URL This is not a valid URL. Please correct it and resubmit."

The incorrect Google XML lists is: http://#/ . In the XML sitempap created by the plugin, I can see that that URL is listed.

I'm not sure where the XML Sitemap generator came up with this URL. In order to get my dropdown menus to work, I set the URL to # on some blank pages that only have a title.

For example, the first child in my navigation is a blank page with a URL set to # and a title of "A-C". The "A-C" page's children are the pages of all of the areas starting with A thru C. I set the "A-C" page's robot meta to noindex, nofollow. Does that have something to do with the problem?

I don't have a page named http://#/. As I don't have a page with this URL listed in my WordPress Pages section, I can't set it to noindex, nofollow. Any suggestions on how to solve this problem?

Thank you.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Okay, I ended up using the Google XML Sitemap plugin. You can input the post id's of the pages you want excluded from the sitemap. I excluded the pages with null links and now Google accepts the sitemap.

share|improve this answer
add comment

I had the same problem. The # was caused by the plugin "Page Links To" for me. This is a plugin that makes certain top level navigation link so that nothing happens when you click it and you have to choose a subcategory.

With Yoast SEO, you need to edit each page using # as a redirect under Advanced settings to "Never Include" in Sitemap. I also chose No Follow and No Index just in case. This then deleted the # link in my sitemap and when resubmitted to google, was accepted.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.