Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Im using the W3 Total Cache plugin on my site, and I made page using the wp_list_comments and for some reason the page keeps coming up blank, it comes back after I disable the plugin but when i enable it everything goes blank again does anyone have a suggestion on how iI can fix this, im new to this plugin.

thanks

share|improve this question

closed as off-topic by birgire, Rarst Aug 22 at 20:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 1 down vote accepted

You can turn off caching for your wp_list_comments template by placing define('DONOTCACHEPAGE', true); at the top of the page.

Other constants available on a per page or template basis are:

  • define('DONOTCACHEDB', true);

    Disables database caching for given page.

  • define('DONOTMINIFY', true);

    Disables minify for a given page.

  • define('DONOTCDN', true);

    Disables content delivery network for a given page.

  • define('DONOTCACHCEOBJECT', true);

    Disables object cache for a given page.

share|improve this answer
    
Thank you for replying, ok i kinda figured out whats causing it to go blank, im using this code <?php wp_list_comments('per_page=23&callback=mytheme_comment', get_comments()); ?> and its get_comments(); thats making the page come back blank, once i take getcomments() out the page works fine, any suggestions? –  Jeremy Love Aug 1 '11 at 23:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.