Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Hi I am trying to add threaded comments to my theme, I have enabled them through the admin settings. Allowing the "Reply" link to show, when posting a threaded comment it appears there is no ul id/class children.

They seem to just be normal comments, I have read some tutorials and all say that when you enable the threaded comments thats it.

share|improve this question
1  
Since it appears you've solved the problem, please post the solution as an answer here (if an existing answer does not solve the problem), and mark it as accepted for future reference. Thanks! –  tnorthcutt Sep 29 '10 at 13:29
add comment

1 Answer 1

If your theme is old (made for WP version before 2.7) you will need to upgrade its code to work with threaded comments. Probably both internal code and styling.

Most fitting article I can find in docs is Migrating Plugins and Themes to 2.7/Enhanced Comment Display

Plus there were major changes to comment form functionality in 3.0, see comment_form() function.

share|improve this answer
    
Thanks Rarst, I'm using the callback method and I believe the theme I'm making is for 2.7 and above. But I'm beginning to guess I need to take a closer look into 3.0 –  Antony Sep 29 '10 at 11:55
    
Ah, I misunderstood it as if you need to update existing theme. For latest stuff I believe it's best to check Twenty Ten theme, it is supposed to be up to date on all of that. –  Rarst Sep 29 '10 at 12:00
    
One step ahead Rarst, I just deleted the input method forms I had in my comments.php. I replaced them with the <?php comment_form(); ?>, and funny enough the threaded comments are working. I just have to clean up the code and style. –  Antony Sep 29 '10 at 12:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.