Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've created a custom taxonomy and I'm trying to get Wordpress to display the taxonomy template when no term is defined. Currently Wordpress is only showing the template when a term is defined on the URL.

My taxonomy is called projects and defined like this:

$args = array(
    'labels' => array(
        'name' => "Categories",
        'singular_name' => "Category",
        'search_items' => "Search Categories",
        'popular_items' => "Popular Categories",
        'all_items' => "All Categories",
        'parent_item' => "Parent Category",
        'parent_item_colon' => "Parent Category:",
        'edit_item' => "Edit Category",
        'update_item' => "Update Category",
        'add_new_item' => "Add New Category",
        'new_item_name' => "New Category Name",
    ),
    'hierarchical' => TRUE,
    'label' => 'Categories',
    'query_var' => TRUE,
    'rewrite' => array(
            'slug' => 'projects'
    ),
);

register_taxonomy('projects', 'project', $args);

Next to this I have created a template file called taxonomy-projects.php.

Currently when I browse to the http://mysite.com/projects URL, Wordpress falls back to the index.php. How can I make it so that when no term is defined, Wordpress shows my taxonomy-projects.php template?

UPDATE:

I should have added this straight away, I'm clearing my rewrite rules each time I make a change to try again.

share|improve this question
add comment

2 Answers

I had a similar issue. I ended up using the archives.php and had a little more luck with that. It would see and use the archives.php (and the archives-video.php I created from it), but would not see taxonomy.php or taxonomy-videos.php or category.php like it should.

share|improve this answer
add comment

Have you tried flushing your rewrite rules?

If not, go to Dashboard -> Settings -> Permalinks, and click "save" (no need to make any changes), to force WordPress to flush the rewrite rules.

share|improve this answer
    
Sorry. Yes. I know about resetting the rewrite rules. I do this every time I make a change. No luck. –  Luke Jul 17 '11 at 2:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.