Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Im using wordpress together with qtranslate and it works on pages and post but not in menus, widgets etc. So i created jquery scripts to solve those issues. The problem is that the field "link_description" in wordpress link section is limited to 30. Using two languages or more, 30 characters is not enough. Is it possible to change or even remove this property without modifying any core files?

share|improve this question
    
I just tried this but in wordpress 3.8 there is a maxlength attribute in place. How could I change that? Do I need to use Javascript or is there a WordPress hook to do so? Thank you in advance for your help –  jcuenin Feb 11 at 12:43
add comment

1 Answer 1

up vote 1 down vote accepted

First of all, "link description" is defined in the database structure as VARCHAR(255), and I don't think there's anything in core limiting the size of the field farther. Are you sure that you can't fit more than 30 characters in your bookmark descriptions?

That said, 255 characters can still be small if you are trying to fit several different language translations into the field. However, there's nothing stopping from you from simply redefining the column type in MySQL so that it can hold more data. Defining that field as "TEXT" would let you store up to 64K in it, and you wouldn't have to modify any core files to take advantage of that change.

share|improve this answer
    
Ah but if you look at the source code on link discription it says "<input type="text" name="link_url" size="30" class="code" tabindex="1" value="{VALUE HERE}" id="link_url"> Even if i've managed to store more then 30 chars in my database, only the first 30 will display in that textfield. And thats tha data i'll try parsing which sqrews up my code, cutting the translated parts :/ –  Richard Jul 16 '11 at 9:32
    
The "size" attribute of an input field (which is a display property, setting the width to approximately the number of characters) isn't the same as the "maxlength" attribute (which actually truncates the value in a text field to that number of characters). The input field as it exists shouldn't be cutting off your value. Maybe you should try posting your jQuery scripts here to see if something in them is causing the problem? –  goldenapples Jul 16 '11 at 15:43
    
Oh, sorry my bad! When changing to varchar(2000) in the db table solved my problem as you suggested! Thanks a million :D –  Richard Jul 19 '11 at 10:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.