Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

After transferring a working WordPress site to GoDaddy hosting, we've begun getting "Error establishing a database connection" errors on all pages- first intermittently, and now consistently. It's strange because it worked most of the time, at least at the beginning, but now errors all the time. This is all within the first few hours of our install- I'm wondering if this might be a database caching issue on WordPress? Is there a cache to clear?

Thanks-

share|improve this question

2 Answers 2

up vote 2 down vote accepted

-First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, etc .

  • double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

-Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.

-Check you have actually created a database with the same database name as is in your wp-config.php file.

-Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

There are also many threads on this topic on WP forums: http://wordpress.org/search/Error+establishing+a+database+connection?forums=1

share|improve this answer
    
Honestly can't remember how I resolved this, but good answer –  Yarin Nov 6 '11 at 16:16

I had the same problem (in a VPS). Tried almost everything (disable all plugins, repair the database, change theme, check logs) until thinking that it could be a server configuration error (indeed I posted it here).

Seeing that it just happened for one of my sites (with WP), I guessed that it has to be a WP configuration error, so I checked again config.php and I saw:

/** Enable W3 Total Cache */
define('WP_CACHE', true); // Added by W3 Total Cache

And yes! Removing this line the error disappeared, probably because this line was repeated somewhere in the plugin directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.