WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a problem with Wordpress permalinks. I change the permalinks to pretty permalinks but I am just getting 404s for the pages now. The strange thing is when I use /index.php/%postname% the page links work fine, but I need to get rid of the index.php part.

I read about making changes to httpd.conf file but can't find the file anywhere. The htaccess file is correct as far as I can find out, it's below

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Any other ideas?

Thanks Emma

share|improve this question
whats your host? – Bainternet Jul 12 '11 at 11:41
Hey, it's a local company, running a server from their shop. They have a very basic web panel! – emmahiggy Jul 12 '11 at 12:20
Maybe check the .htaccess file permissions. Maybe WP can't get to it? – Cristian Jul 12 '11 at 12:38
I have the file permissions for the htaccess file set to 644, the permalink is changing but the pages are not changing with it so I'm getting 404s when the permalink is correct. – emmahiggy Jul 12 '11 at 14:28
What's the exact value of the permalinks setting? – Alex Older Jul 12 '11 at 14:39

10 Answers 10

I had all the correct code in the .htaccess file, but it ended up being completely overridden in the Ubuntu default /etc/apache2/apache2.conf file as well. Changed the entry for / and /var/www from AllowOverride None to AllowOverride All, restarted Apache and now everything works just fine.

share|improve this answer

My guess is that mod_rewrite is not enabled. Depending on what server you are using, enable mod_rewrite.

Then, if you are on Linux, manually edit /etc/apache2/sites-enabled/000-default and change AllowOverride for from None to All (or where your site's directory is).

Here, at points 3 & 4 should be solutions for Windows.

share|improve this answer

Are you by any chance using Names.co.uk as your host?

I just had the same problem as you, and after a couple of hours of Googling I found out that they use a Zeus server - not Apache - and it does not support the Mod_ReWrite function. This seems to account for the confusing symptoms. (I had no .htaccess file - but no errors reported from Wordpress whenever I made a change to my permalink preferences.)

They have a workaround for Zeus, detailed here:


I realise this is a couple of months after your original post and you've probably solved it by now - but for anyone who finds this in the future it would be a good idea to check if your host uses Zeus or some other non-Apache server.

Update: Please see the code I posted here on a similar question

share|improve this answer

Try setting the htaccess to 777 then go in and update the permalink settings to what you want, then if it works go back and change it back to 644

share|improve this answer
Hey, tried that, no luck, thanks anyway. – emmahiggy Jul 13 '11 at 15:16

After adding my content I found an article that suggested deleting the .htaccess file, then go to Settings/permalinks and remove the index.php. The article said WorPress would give an error suggesting you create the .htaccess file. I decided to try it but it did nothing. What I did find out is my permalinks were still working with the deleted .htaccess file. This puzzled me at first. I opened my FTP client and navigated to my files. I noticed that there was a .htaccess file there after I had deleted it. I don't know if it is WordPress, my Hosting Account or what exactly created it but I know this is new. This didn't happen before. You might try this method if all else fails.

I wasn't able to re-create the problem in your question so I'm not 100% sure if it works for you. It's worth a shot though.

regards, Jeremy Jared

share|improve this answer
Hi, tried the above and no luck, the htaccess file didn't recreate itself, but the permalinks setting didn't work so I just uploaded the htaccess file again. Thanks anyway – emmahiggy Jul 13 '11 at 15:18

Try replacing the .htaccess code with this:

# -------------------------------------------------------------------------
# Rewrite Engine options
# -------------------------------------------------------------------------

RewriteEngine On
RewriteCompatibility2 On
RepeatLimit 200
RewriteRule ^/index.php$ / [NC,P,R=301]
RewriteCond %{REQUEST_URI} !/wp-admin
RewriteRule ^/(.*)/$ /index.php/$1 [NC]

# Redirect 'www.yourblogsite.com/anything/anything/index.php'
# to 'www.yourblogsite.com/anything/anything/'

RewriteRule ^/(.*)/index.php$ /$1/ [NC,P,R=301]

# -------------------------------------------------------------------------
# -------------------------------------------------------------------------

I still had the log-in credentials to a client I had to fix this for. This is what I used for him. It is an IIS Server, I'm not sure if that matters but you can try it. Good Luck, JJ

share|improve this answer

I think your host uses ISS. ISS uses "URL Rewrite" not "mod_rewrite", so take a look at the Codex.

"Pretty" permalinks usually require mod_rewrite, and IIS (common on Windows servers) does not support mod_rewrite. (If you are using Apache 2.0.54, on Windows, mod_rewrite may work, provided it is enabled in apache\conf\httpd.conf.)

share|improve this answer

I know its too late to reply now but if you are still looking for this; here is a quick way to that:

Solved- How To Remove Index.php From WordPress URL On IIS7?

share|improve this answer
Please, add a solution to your Answer, if the link dies, this won't be useful anymore. – brasofilo Mar 10 '13 at 14:34
@brasofilo Mother of god....! Link dead! ;) – Sunny R Gupta Oct 15 '14 at 14:24

I was having this issue on Mac OSX and the following was very much useful. It seems that by default Mac's are not .htaccess ready by default and Apache will ignore the file until certain files (specified on the links below) are modified:



Hope that helps!

share|improve this answer

I have been battling this issue for a while, and today I resolved this problem. I found out that my mod_rewrite wasn't enabled all this while. I found the information on this link very useful. It explains everything from how to check if the mod_rewrite is enabled, and if not - how to enable it. I hope this information is useful for anybody who is new to WP and struggling with setting pretty permalinks.

share|improve this answer
All relevant information should be part of your answer, especially your answer shouldn't be depending on external links, because the information there might disappear and then your answer is more or less worthless. So would you please add the information to your answer - thanks. – ialocin Jan 8 at 13:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.