WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This problem is driving me crazy. So, I've Jetpack installed and the Gravatar hovercards activated. I could live without them, but other "hover over image" functions (e.g. I'm using the Guan Image Annotation plugin that lets you add a note to an image in a post by hovering over it) don't work either.

It still worked earlier today and all I did was activate and deactivate a few other plugins. I tried to figure out with plugins are causing the misfunction, but couldn't figure it out. Maybe it's not a plugin interfernence after all. I just can't seem to figure it out :(

As I'm a total beginner I'm not sure, but I think both (hovercards and the mentioned plugin) work with javascript? So maybe something is interfering with that?

I hope you can help me figure this out. My (under construction) website is here.

Thanks a lot in advance for any kind of advice! :)

share|improve this question
up vote 1 down vote accepted

If you look in the source code of your homepage, in the header you will see that you have a lot (infact i have never seen as many jquery files in a header before) calls to jquery files, this is definatly a cause for conflict if two of the files are the same, i can see at least 2 references to a similar file.

What you will need to do, is deactivate all plugins, and start reactivating them one by one, each time testing the site, eventually you will activate the plugin that is breaking your jquery what you can do then is open up that plugins files and comment out the line that calls the jquery file and see if it will run off the other one..

these could be the issue


share|improve this answer
Thanks a lot. I've removed a few of those and I will try deactivating all plugins tomorrow and then let you know. – japanworm Jul 10 '11 at 15:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.