Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Ater rebooting a memcache node, I am getting an error on root blog only, with a telling error log message from wp-includes/ms-settings.php.

[Thu Jul 07 18:55:27 2011] [error] [client 12.34.56.78] PHP Warning:  Attempt to assign property of non-object in /var/www/domain.php/wp-includes/ms-settings.php on line 114

Dumping the $current_blog var from that file shows there's no site data loaded into the object, just a couple plugin references, which is why lines like these are failing:

    $blog_id = $current_blog->blog_id;
    $public  = $current_blog->public;

How can I clear site options in memcache by hand? What are the keys?

share|improve this question

1 Answer 1

The variable in my copy of wordpress on the line your error indicates is actually $current_site as opposed to $current_blog (I may have a newer version of WP). I believe you can clear that by changing the value of the option_name "siteurl" or "blogname" in your wp_options table on your database.

share|improve this answer
    
$current_site was probably a slip (mid-outage, I was going nuts). It turns out that it was not the database -- just the cached version in memcache -- so this wouldn't have helped. I actually just needed to delete memcache key by hand. Thank you for the answer, but I'd still like to see the key/value pair under which this is stored. –  editor Jul 7 '11 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.