Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a site that is setup for WordPress multisite. The main site works, but the subdomains are not functioning as I would like them to.

Here are the settings for the main site:

Upload Path: media/images/national Upload URL Path: http:// images.mydomain.com/national Fileupload Url: http:// www.mydomain.com/media/images/national

These settings work, and I am able to upload images to the specified folder. However, when I try to use similar settings for any of the subdomains, WordPress ignores my settings and use its default settings, which are:

Upload Path: wp-content/blogs.dir/4/files Upload URL Path: (blank) Fileupload URL: http:// cityname.mydomain.com/files

I want all of my media files to go to my media folder and not the wp-content/blogs.dir folder. How can I get WordPress to use the settings I place in Upload Path, Upload Url Path and Fileupload Url instead of it defaulting to it's own settings?

Final note: this also happens on a fresh install.

share|improve this question
    
shouldn't wp_upload_dir() take care of this for you? –  onetrickpony Jul 7 '11 at 16:15
    
wordpress.org/plugins/network-shared-media This plugin appears to take care of all of that! –  Brad Griffin Feb 10 at 15:34
add comment

1 Answer

In a multisite setup, you need to adjust the upload_path for each individual site through the Network Admin menu.

Go to /wp-admin/network/sites.php. Edit the site in question. On the settings tab, you can find the Upload Path setting and change it to whatever you want.

You can also adjust the URLs on this page. Look for "upload".

Note that this doesn't apply retroactively. Only new uploads will be affected.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.