Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

On a Wordpress based website, when I add text using wordpress visual editor or HTML source to a particular page - it gives "page not found error". I tried by adding some other text and its working fine. Then I typed all the text again and in between kept checking if it is giving any errors. Finally I am able to point to the exact word that is causing problem - from. If I put frm , rom or from it works. Only when I use "from" - it gives page not found error. Another thing, the error is only this page not on any other page. I have used "from" on many other pages and there is no problem at all.

Its a client website and I do not have access to the server. I only have wordpress login/password. Any help would be appreciated.

Update: I even tried HTML entities and it does not work. Right now we are using "fróm" instead of "from" as a workaround.

share|improve this question

migrated from stackoverflow.com Jul 7 '11 at 14:49

This question came from our site for professional and enthusiast programmers.

    
You're getting a 404 if your page content contains the word from? –  polarblau Jul 5 '11 at 9:07
    
@polarblau: Yes –  RubyDev Jul 5 '11 at 9:26
    
@Keoki Zee: let me know more details you require. Your suggestion about posting to WordPress Answers is great. Can I migrate the question there since it is purely related to WordPress. –  RubyDev Jul 5 '11 at 9:27
    
That sure is a good one. Could you post some of the code in question? –  polarblau Jul 5 '11 at 10:24
    
@polarblau : It is just some content given by the client.. no matter what the other content is, it just do not accept "from". The moment you put from and view preview or publish the page, the page is gone. I think it is some bug in WordPress. Another relevant information is the we are using 'pretty urls' . –  RubyDev Jul 7 '11 at 3:01

3 Answers 3

up vote 0 down vote accepted

What form are your pretty permalinks taking, and what is the title of that page? I've had something similar happen and it had to do with the page title. Try flushing your permalinks (go to Settings > Permalinks and switch to a different default, save, then switch back again to what you were using).

Though of course this doesn't explain at all why putting the word 'from' in the body of the post would make any difference at all. :(

share|improve this answer
    
Thanks, it works :) –  RubyDev Jul 9 '11 at 17:15

Found this solution in Wordpress.org site you need to add this line into your .htaccess file.

BEGIN 404 Fix

< IfModule mod_env.c > SetEnv MODSEC_ENABLE Off PassEnv MODSEC_ENABLE < /IfModule >

END 404 Fix

Hope this will help out your problem

share|improve this answer

Just had exactly weird "from" word issue on a single post, and traced it to Wordpress SEO plugin by Yoast. It may be a sum of other causes for sure, as this got away so far up to this versions. Using the latest versions by now:

  • Wordpress SEO plugin by Yoast, Version 1.6.3
  • Wordpress 4.0

Deactivating Wordpress SEO plugin, instantly allowed me to edit the post again, the post in which I had just added the word "from", two times, in the last edit.

Flushing the permalinks, or changing the post slug did nothing in my case. Anyway, as long as the Edit page url is like: /wp-admin/post.php?post=4076&action=edit, I don't see why permalinks would matter..

I would hint that there is a bug in the way Wordpress SEO plugin does the text analysis to gather keyword calculations.

UPDATE: - removing the "from" word in the post did not solve the not found error, but disabling Wordpress SEO does.. so there may be other words or other related issues! - MODSEC_ENABLE solution causes 500 Internal server error

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.