Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've just upgraded from 3.1.2 to 3.2, and now "featured image" is no longer listed at the bottom right of a post in admin.

Has this feature of WP been removed?

Can it be added back, or turned back on?

My old posts still have their old featured image, but it cannot be added to new ones.

share|improve this question

5 Answers 5

For me, "Featured Image" was still missing from the Screen Options tab, even after clearing the cache and restarting the browser. In my case the problem was related to having a WordPress 3.2 Multisite install. With this setup, the Media upload buttons must be checked in Network Admin to enable the featured image meta box in the editor (these are unchecked by default). From the WordPress Codex:

To show the "Featured Image" meta box in mulsite installation, make sure you update the allowed upload file types, in Network Admin, Network Admin Settings SubPanel, Upload Settings, Media upload buttons options. Default is off.

share|improve this answer
    
dude.. thanks!! –  Ünsal Korkmaz Dec 3 '11 at 2:27

Have you looked in the Screen Options tab (top right on the Add Post / Edit Post page) to make sure 'Featured Image' is checked? It may not be set to show up by default but it should be there. Once you've checked the box it will remember your preferences.

share|improve this answer
    
No, I didn't realise it was there. I had to restart my Firefox browser, and it has magically reappeared. Thanks for your help. –  Steve Jul 6 '11 at 16:21
    
No problem, glad you were able to find it okay. –  Michelle Jul 6 '11 at 19:07
up vote 0 down vote accepted

I had to restart my browser, and after logging back into admin featured image has reappeared. I made no changes to settings.

share|improve this answer
1  
WordPress 3.2 bumped up the version of jQuery that WordPress uses. It may be that the jQuery script cached in your browser simply needed to be reset. –  Chip Bennett Jul 6 '11 at 16:54

Add this to your functions.php:

<?php the_post_thumbnail();?>

If its still not working, go further with these steps: http://www.blog.web6.org/wordpress-3-0-set-featured-image/

share|improve this answer
    
The functions.php is the wrong place for that, it should be in a template file. –  toscho Nov 9 '12 at 21:13

You have to put following code in the functions.php

add_theme_support( 'post-thumbnails', array( 'post', 'page' ) ); // Add it for posts
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.