Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I originally designed the site without the www. I've since realized that it's going to cause more problems than necessary.

I created a rewrite rule that converts to www.

I then changed the domain in wp-config

define( 'DOMAIN_CURRENT_SITE', 'openeye.net' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );
define('WP_HOME','http://www.openeye.net');
define('WP_SITEURL','http://www.openeye.net');
define('WP_MEMORY_LIMIT', '96M');

I'm now not able to edit pages or access wp-admin. What would cause that?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

You don't need a rewrite rule in .htaccess to add www back in. Remove the rewrite rule, remove all the defines in wp-config and try to login. If that doesn't work, delete permalinks in .htaccess to force them back to default.

After you're in, add the www in Dashboard>>Settings and save. Then reset permalinks.

share|improve this answer
    
That's exactly what I did last night and it worked perfect. –  Zach Shallbetter Jul 6 '11 at 20:19
add comment

Are you able to access your DB? Check that your site url is correct in the wp_options table.

From WordPress's perspective, what you've actually done is "moved" your web site to a completely different URL (just as if you were to forklift your site from "mydomain.com" to "anothersite.net". This can often cause login issues, but if you follow the instructions in these two articles I think you'll be just fine.

share|improve this answer
    
Yeah I followed both and have access to the DB. I wonder if it's because I'm defining the domain in wp-config. It's possible that it's causing odd conflicts. –  Zach Shallbetter Jul 5 '11 at 22:55
    
Yea, I overlooked that line... Definitely try updating that, and then double check that the wp_options table has the www version of your domain too. –  Jared Cobb Jul 5 '11 at 22:57
    
Still no dice. When I try to access wp-admin it redirects to this openeye.net/… –  Zach Shallbetter Jul 5 '11 at 23:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.