Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am a little confused, the Wordpress 2.8 Widget API reffers to WordPress version 2.8 or is refferred to API version?

Should I use 2.8 Widget API for writing my WordPress 3.1.4 widget?

share|improve this question
1  
The widgets API was introduced in Wordpress version 2.8. And its still used, so Yes you can use it for your Wordpress 3.1.4. Here are the docs: codex.wordpress.org/Widgets_API –  Hameedullah Khan Jul 3 '11 at 8:03
add comment

1 Answer

up vote 1 down vote accepted

WordPress APIs usually refer to group of functions and concepts and are not versioned. Any versions refer to WP itself (or in some cases to bundled components, developed by third parties such as jQuery).

In WordPress version 2.8 creating widgets was refactored from older code (which you shouldn't care about) to newer class-based code (which you should use).

So it's not like it is exactly same as it was in 2.8 (likely it isn't) but approach is same since then.

share|improve this answer
    
Thanks doubt clarified. –  Hans Zimermann Jul 3 '11 at 20:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.