Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i've been having a world of difficulty w/ the WP-minify plugin. usually i get 400/bad request errors when i try to access the combined/minified script or style files. this tends to break the entire look of my site. but on my last site i came across a new error... when i try to view the combined script i see the following warning/errors followed by a bunch of gibberish.

anybody know what the heck this is about?

`
Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/home/kathyi/public_html/wp-content/plugins/wp-minify/cache//minify_2fac368eb244a71e24b5c8bb929e8107.gz) is not within the allowed path(s): (/var/www/vhosts/soulmatesummit.net/httpdocs:/tmp) in /var/www/vhosts/soulmatesummit.net/httpdocs/online-course/wp-content/plugins/wp-minify/min/lib/Minify/Cache/File.php on line 71

Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/home/kathyi/public_html/wp-content/plugins/wp-minify/cache//minify_2fac368eb244a71e24b5c8bb929e8107) is not within the allowed path(s): (/var/www/vhosts/soulmatesummit.net/httpdocs:/tmp) in /var/www/vhosts/soulmatesummit.net/httpdocs/online-course/wp-content/plugins/wp-minify/min/lib/Minify/Cache/File.php on line 33


Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/home/kathyi/public_html/wp-content/plugins/wp-minify/cache//minify_2fac368eb244a71e24b5c8bb929e8107.gz) is not within the allowed path(s): (/var/www/vhosts/mysite.net/httpdocs:/tmp) in /var/www/vhosts/mysite.net/httpdocs/online-course/wp-content/plugins/wp-minify/min/lib/Minify/Cache/File.php on line 33

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/mysite.net/httpdocs/online-course/wp-content/plugins/wp-minify/min/lib/Minify/Cache/File.php:71) in /var/www/vhosts/soulmatesummit.net/httpdocs/online-course/wp-content/plugins/wp-minify/min/lib/Minify.php on line 312


`

share|improve this question
    
why don't you minify your javascript yourself ? –  onetrickpony Jun 30 '11 at 16:28
    
b/c it is easier to keep all my files separate for editing and then combine them all on-the-fly –  helgatheviking Jul 1 '11 at 16:06
add comment

1 Answer

up vote 0 down vote accepted

"open_basedir restriction in effect" errors mean the host is very restrictive in terms of php configs. The open_basedir setting prevents scripts from reading files (via requires, includes, any of the file handing functions, etc.) from directories that are not marked as "safe." It was designed to prevent users from accessing sensitive files and/or other user's files shared servers while PHP was running as "nobody."

If you have Cpanel or Plesk, etc., try switching to the CGI version of PHP using suPHP. But if you can't, find a new host.

share|improve this answer
    
ahh that makes sense. i have had a lot of issues w/ permissions w/ this host. not my choice of host and i probably have no say in who they company uses, "i just work here" –  helgatheviking Jul 1 '11 at 16:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.