Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

In the multi-site wordpress install, you get a very nice "upload settings" in the network admin settings. (see attached image).

I am trying to change these settings without using php.ini for a single-site wordpress install and I can't find them anywhere... help?

Tim

Attached: Network Admin Settings Example: Network admin example

share|improve this question

3 Answers 3

up vote 1 down vote accepted

create an file php.ini and copy via ftp or ssh to wp-admin; inside this file the follow values; play with values for test and see the result.

memory_limit = 32M
upload_max_filesize = 32M
post_max_size = 32M
file_uploads = On
share|improve this answer
    
Thanks - this is indeed the fix. However, my hosting company blocked access to the php.ini (shared server) so I had to contact them to get the change made. Thanks! –  timshutes Feb 19 '12 at 23:18

Maybe this thread can help you? http://wordpress.org/support/topic/how-do-i-change-my-upload-limit?replies=6?

It suggests changing settings in php.ini and/or .htaccess

share|improve this answer
    
unfortunately - I don't have access to the php.ini file (shared server) and when I made those suggested changes to .htaccess I got an internal server error... –  timshutes Jul 1 '11 at 14:18
    
You can add the value if php.ini also in a file in wp-content, write a new value and works. –  bueltge Feb 12 '12 at 22:41

I wound up contacting the customer support for my hosting company and they made the change. I found out that the difference between wordpress single install and multi-site is that multisite lets the superadmin drill down into specific sites and set the limits for those sites. In terms of the overall limit, wordpress single site doesn't "care" about that, and just reflects what is set on your own server.

If you have access to php.ini, you can change this setting yourself. Otherwise, you're at the mercy of your hosting company.

Best of luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.