WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My WordPress now is at version 2.7. I want to upgrade it to 3.0.1 using Auto update function. I'm using FTPS connection type.

The upgrade should be straight forward, however, I keep on encountering this error:

Installation Failed Downloading update from http://wordpress.org/wordpress-3.0.1.zip

Unpacking the update…

Verifying the unpacked files…

Installing the latest version…

Could not copy file.: /wp-admin/css/theme-editor.dev.css

Installation Failed

I've checked the permission for the /wp-admin/css folder, and it's set to 777.

What is the problem? I've searched the internet, but it seems that a lot of people has the same problem.

Any ideas?

share|improve this question
2.7! It's about time. ;-) – Arlen Beiler Aug 14 '10 at 18:01
up vote 2 down vote accepted

Auto update doesn't always work, it almost always works. I'd just upgrade manually and not worry about it. The few times I've had an auto update failure it succeeds the next time a new version comes out (after I'm manually updated during the breakage).

share|improve this answer

There's a patch (http://core.trac.wordpress.org/ticket/10913) for WordPress that should go into 3.2 and help fix this upgrade error for most people running into it. It only seems to happen with servers running Pure-FTPd. In the meantime, there's a plugin that should help fix updates for most people: http://wordpress.org/extend/plugins/ftp-upgrade-fix/

share|improve this answer

Check the permissions on the file referenced. In this case: /wp-admin/css/theme-editor.dev.css.

share|improve this answer
I've checked the permission of that file as well, yet I still have the same problem. – Graviton Aug 13 '10 at 4:03

Check the Owner of the file/s you may have it set 777 but if the ftp service is not in the owner group or the owner this may your problem

You need to telnet into the web server to check/fix this us ls -l to see the settings chown is the how you change it

share|improve this answer
Well, I make sure that both the file and the folder where the file is contained has 777 set for the permission. – Graviton Aug 16 '10 at 3:13

this has been discussed and explained here: http://nabtron.com/wordpress-update-could-not-copy-file-wp-admincsstheme-editor-dev-css/2714/

share|improve this answer
@Nabeel, I've tried the solution, but it still didn't work. – Graviton Aug 21 '10 at 12:04
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – kaiser Aug 30 '12 at 13:08

I tried everything for the auto upgrade that was mentioned at wordpress.org/support/topic/upgrade-gone-worng-pls-help, but to no avail.

Instead I did a manual upgrade more or less following the instructions at codex.wordpress.org/Upgrading_WordPress. Instead of using FTP, I used my hosting providers CPanel - I then blogged the steps I took so that others might benefit - see http://misterjaytee.com/2010/09/11/errors-updating-wordpress.

Hopefully the next Automatic upgrade will work properly, but if not, I now have the confidence to do the upgrade manually.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.