Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've worked with WordPress for a while now and this is the first time I've had this problem, I can't get my permalinks to work without index.php on the URL even though mod_rewrite is enabled, a few things that might help figure the problem out:

  • I'm using apache2 and mod_rewrite is enabled, I doubled checked by displaying the phpinfo()
  • The .htaccess file gets written just fine when I update the permalink options and the contents are default WP Redirect rules but just in case here it is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
  • The permalink common settings on the option page don't actually show the /index.php/ part (sometimes when I've used IIS they show it there), if I use any of the common url structures I get a 404 page (not the 404.php one on my theme but the browsers 404 one) but if I add /index.php/%postname%/ for example it works just fine.

Does anyone know what might be wrong? Thanks in advance!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Sigh had to add this to the httpd.conf file on the webserver:

<Directory /var/www/>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
</Directory>

First time I have to add it manually, oh well it works fine now :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.