WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I moved my word press blog from Apache to IIS 7 shared hosting. my database connection is fine. I can access the admin module but I get an empty index.php with "Nothing Found for Index Php Error" in the title bar. Can someone please help.

share|improve this question
up vote 0 down vote accepted

Start by going to Settings>Permalinks, now click on the default radio button and click save. You probably used .htaccess to enable pretty permalinks, IIS doesn't use an .htaccess file.

If the default structure fixed the problems you are having, but you want the old permalink structure, click this link to the WP-Codex page explaining how: Link to Codex Page (about half way down).

share|improve this answer
Thanks .. Jeremy .. It worked except having the old permalink part. I am not able to use permalink. Even though it is IIS 7 ,may be because of "URL Rewrite " module is not there. – Mohit Jun 28 '11 at 14:17
I'm not an IIS Expert, but I've dealt with enough to know I prefer Linux 100%. I would never switch on purpose. If you need help installing the rewrite module, post your progress and problem, maybe I can help. – Jeremy Jared Jun 28 '11 at 14:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.