Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a version 3 installation of wordpress on my hosting package that I installed myself

Everything else so far seems ok such as posting etc, but I'm unable to install any new themes

I have tried to install a theme from clicking one of the "featured" themes, and have tried to upload a ZIP from the wordpress themes website, but each time it just hangs on "Unpacking" or "downloading" and nothing ever happens, I don't get any errors

I've noticed that under /wp-content/uploads I can see a zip I select for upload, its filesize seems ok

Any ideas?

share|improve this question
    
I am experiencing the same behaviour with plugins, however I was able to install an AdSense plugin ok.. :S –  user155695 Sep 22 '10 at 20:04

2 Answers 2

up vote 5 down vote accepted

This problem most notably occurs on systems running PHP4. If you can, upgrade your server to PHP5 (if you're on a hosted server, there's usually a setting in cPanel or whatever administrative tool you have to switch from PHP4 to PHP5).

share|improve this answer
    
Correct, creating a simple phpinfo file exposed version as PHP Version 4.4.9. +1 and thanks :) –  user155695 Sep 22 '10 at 20:34

I would also check the permissions on the affected directories. It doesnt sound like thats the issue, but they have a habit of cropping up in WP

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.