Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have an issue with text in my posts. The site is http://2buntu.com.
As I don't own the server, I cannot get direct access to some things. I don't know what caused it but I think it was a plugin I activated. Since then I've tried deactivating plugins, but nothing worked.

I have tracked the source of the problem with the help of a friend, now I need to find a way to fix it (if that is even possible on my end).

"MYSQL query returned error executing query "SELECT term_taxonomy_id FROM wp_term_relationships_img AS img WHERE img.object_id = ORDER by term_taxonomy_id" : => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER by term_taxonomy_id' at line 1"

That is the error we get. The problem was with an image tagger plugin. I removed the plugin but wordpress is still giving trouble.

I forgot to mention, the posts are not wiped; I can edit them, etc. They just render as blank.

Update:
Site is still not working. I deleted the offending plugin and the table it was using, but it seems post are still not having their content rendered :(. Please! I need help!!!

share|improve this question
add comment

2 Answers

If you are unable to retrieve the posts through the Database so you can check the tables, try doing a Google Search for the posts. Type the page URL into the Google Search and look for a cached version. This is definitely not the optimal way to recover the posts, but will work in a worst case scenario.

share|improve this answer
    
the posts are still there, they just render blank. –  RolandiXor Jun 26 '11 at 3:13
    
Try opening your wp-config.php and changing define('WP_DEBUG', false); TO: define('WP_DEBUG', true); Now you should see any PHP errors. –  Jeremy Jared Jun 26 '11 at 4:36
    
How would I access this? I tried to navigate to it, but then realized I can't. The problem is I don't have direct access to the host (I could let him set this up, but so far have not yet). –  RolandiXor Jun 26 '11 at 11:41
add comment

A friend on AskUbuntu's chat room (Oli) gave me a tip - disable all plugins. I did that and there we are!

Everything is back - except I now I have to reenable a lot of plugins :/...

If found the real culprit too. The facebook like button plugin I had enabled. I deleted it now (wasn't working well anyway).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.