Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using wordpress version 3.1 and if I try to upgrade any plugin on any of my sites I get the error message error: An Unexpected HTTP Error occurred during the API request. Not by upgrading automatically, but manually upgrading through the dashboard plugin area I guess I mean

I've google for a solutions, to no avail. I've gone into my class-http.php file and changed this code 'timeout' => apply_filters( 'http_request_timeout', 5), to 'timeout' => apply_filters( 'http_request_timeout', 30), Also tried request time out at 60.

Also downloaded Core Control Plugin, went into External HTTP Access and disabled each of those 4 PHP HTTP Extension/Transport options one by one and still same problem.

share|improve this question

2 Answers 2

I had the same problem before. When I asked my friend, who is maintaining the server, he answered me that it's because of the server firewall. When he turned of the firewall, everything was ok (plugins can update, akismet can check for spam, etc.).

So, if you've checked all your settings with Core Control (make sure that all the tranports are turned on) and the problem still happens, you should ask your host provider for the firewall settings, just like me.

Hope that helps.

share|improve this answer

First thing to do is make sure no plugins or theme is breaking the upgrade process. So firstly disable all plugins and switch back to the default 2010 theme. The try the upgrade again.

If you are still unable to get this to work then you are aware that you can upgrade the old fashioned way by ftp?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.