Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This is the oddest thing I've ever seen on wordpress. Here's my problem:

I have a whole ton of text. But the last few lines I have this:

< blockquote>[Laughs] I'm doing the exact same thing I'm doin' live. Plug in, turn it up, turn on the machine and play. I don't overdub anything. I ain't going back and redoing solos. I ain't going back and redoing vocals. It's all live. If you listen, you can hear the guitar pick clicking on the strings while I'm singing! So I'm playing it live just as if I was in front of an audience. And that's the way it feels in the studio when everybody's playing together and you're not going back and fixing anything. Because you know I'm really kind of a stickler for that.

IF I add this line next (without the quotes)...

"I try to keep anybody from having to go back and fix anything so it makes them have to play it now, you know?"

The entire body of the post disappears. Only the title shows up. If I remove that line, the text comes back. If I add "asdf", the body stays. If I add a random line, the body disappears. I thought maybe it was a phantom html tag hidden in there or something, so I copied and pasted into notepad to clear any potential underlying formatting and it's still doing it. I've never seen anything like it. I've been poking at this thing for hours. I even tried moving the entire contents to a new post. No dice. I erased and rewrote the entire offending section and then some... nothing. We've got several hundred posts and this has never happened. There's a good 20 blockquotes in this post and everything works fine. We don't really have any plugins that scan text or anything that would be screwing with this thing. For the life of me, I can NOT figure out what in the world is going on........

Does ANYBODY have ANY ideas?!

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Maybe the blockquote or it's containing elements are floated with CSS and by adding one more line, the size of it grows too large to fit in the theme / page layout, and the whole post body gets shifted down or out somewhere where it's not visible anymore.

You can try the Firebug extension for Firefox, which is an excellent tool for debugging issues like that. But you'll need to know HTML + CSS to take advantage of it.

share|improve this answer
    
Yeah, I've checked the HTML/CSS a million times. What I ended up doing was moving the offending text around to see if it would make it disappear in other places. It did -- but then in certain places it didn't. Long story short, it just... started working again, at a time when it shouldn't have. I spent another hour trying to figure it out before I gave up. I SINCERELY hope nobody else runs into this problem... –  Cyprus106 Jun 24 '11 at 14:09
add comment

If anyone else is running into this, try following the advice here, re: PCRE limits in your PHP settings (or at the beginning of your wp-config.php file, or both). Sounds like it could be your problem—a very long post, with shortcodes, showing up empty on the front end even though it shows up fine in the editor.

http://www.undermyhat.org/blog/2009/07/sudden-empty-blank-page-for-large-posts-with-wordpress/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.