WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am facing 500.0 Internal server quite frequently with my website.

The error details are given below.

HTTP Error 500.0 - Internal Server Error
C:\PHP\php-cgi.exe - The FastCGI process exceeded configured activity timeout

Module  FastCgiModule
Notification    ExecuteRequestHandler
Handler PHP_via_FastCGI
Error Code  0x80070102
Requested URL   http://mydomain.com:80/index.php
Physical Path   C:\HostingSpaces\coderefl\mydomain.com\wwwroot\index.php
Logon Method    Anonymous
Logon User  Anonymous

When I contacted the support team, they're saying that my site is making heavy SQL Queries. I am not sure how to debug this. But my site is very small and the database is optimized. I'm running wordpress as platform. How to resolve this issue.

share|improve this question
what is your permalink structure?.. heavy sql queries can often be associated with custom permalinks that can hammer resources – MartinJJ Jun 21 '11 at 7:19
It's in the format domain.com/Year/Month/Date/Title-of-the-blog-post A sample URL would be like this ( codereflect.com/2011/06/08/software-is-free-but-the-service ) – sarat Jun 21 '11 at 10:06
What Plugins do you have installed/active? – Chip Bennett Jun 21 '11 at 13:23
up vote 1 down vote accepted

Your site codereflect.com is not that heavy. Could be the Suffusion theme and its options making lots of DB calls. I'd use http://wordpress.org/extend/plugins/debug-queries/ to see what queries are being called and how many. And it also could be you're on a shared box at softlayer that is "too" shared with others.

share|improve this answer
Thank you. I actually called the technical support team and scolded them like anything as my part is clear. The changed my blog's application pool at their server now it seems work fine. – sarat Jun 23 '11 at 14:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.