Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

First of all, I have posted a very similar question here:

Displaying custom post-types in a Fancybox div and then linking to them

However, after being unable to find a solution I have taken a different approach and created a template page with just the portfolioProject div and not included the other elements such as header and footer. So now on this page( click here) when I click on one of the thumbnails it opens up the fancybox div but I have a few issues:

  1. The close button doesn't appear to work
  2. The second thumbnail doesn't appear to work but the first does
  3. I don't want the scrollbar to show, and I have tried using the option scrollbar : 'no' but it does not seem to work

Any help on this would be great! Thanks,

Ash

share|improve this question
add comment

2 Answers

This follow-up no longer seems to fit here in WordPress Answers, but here's what I think:

  1. Close button works fine for me on all thumbnails (Chrome 16 on Mac);
  2. The thumbnails which did not work need to be <a class="fancybox"..., which they weren't;
  3. You can probably try a CSS-only alternative for hiding scrollbars, which is overflow: hidden; since your using iframe fancyboxes, you might want to precede the element which you want to suppress scrollbars with #fancybox-wrap or #fancy_outer or something on those lines, so you can remove those scrollbars only when the page is rendered inside a fancybox;
share|improve this answer
add comment

Im using Chrome 12 on Mac.

  1. The close button works for me but clicking outside the box does not close.
  2. All the thumbnails work for me.
  3. I believe the correct syntax would be scrolling: no (Fancybox)

I notice you are using the Fancybox for Wordpress plugin, most of the options should be able to set in the admin panel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.