Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I use the Google XML Sitemaps (Wordpress Plugin) and the latest wordpress version. Recently i have had a lot of 404 not found errors in webmasters. The urls show up without any categories and it links to the sitemap.xml file. It shows the url as http://mysite.com/welcome-to-my-site/ instead of http://mysite.com/general/welcome-to-my-site/

Since the categories are missing these links return a 404 not found error. These faulty links are piling up and i am in a fix. Please help.

share|improve this question
    
Flush your permalink settings by visiting the permalinks settings page and hit save and then go to the sitemap plugin and do a manual rebuild. After that does it still use incorrect links? –  Brady Jun 13 '11 at 14:50

1 Answer 1

up vote 0 down vote accepted

the XML sitemaps plugin should be pulling your URL structure that you've set in the permalinks setting. Are you using a plugin or other method to remove the /category-name/ from the URL?

share|improve this answer
    
so far as i know i do not have anything that interferes with permalinks. I use a plugin called seo search terms tagging but i am not sure if it has to do anything with missing categories. –  NiceGurl Jun 13 '11 at 13:46
    
What is the permalink structure you have set in your settings? Also, a link to the actual site would be very helpful. –  Norcross Jun 15 '11 at 3:43
    
well i noticed another weird thing. The "faulty" links that show up in webmasters are actually not present in my sitemap.xml file. So far as the permalink structure goes i use /%category/%postname%/ The link to my site is howdoyouloseweightfast.com –  NiceGurl Jun 15 '11 at 6:04
    
OK. I did a quick check using the Xenu link sleuth (seomoz.org/blog/…) and I can see a handful of links that are broken, either tied to a plugin or old site build. Keep in mind that the 404 errors are people that are trying to access links on YOUR site from an external source. Look to see what the links are and set a 301 redirect to where they are supposed to be going. –  Norcross Jun 15 '11 at 17:59
    
Thank you so much for some guidance. Now i know where to look. Thanks again for your help. –  NiceGurl Jun 20 '11 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.