Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i got a wp site with the WPML plugin and the CFT plugin. I set up custom fields for posts and what i'm trying to do is to keep the content of an input type file from the original post to its translation. That would save time as the pictures are the same between both posts and also save disk space on the ftp.

So far i couldnt get it working, not even to get basic input type text automatically pasted from the 1st post to its translation. I tried the different options in WPML > Translation management > Mutlilingual content setup > Custom fields translation without any result.

PS: am using WP 3.1.3, WPML 2.0.4.1 and CFT 1.9.2.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The latest version of WPML (version 2.3) has a new module for Media and this module takes care of the previous images issue. Now there is no longer the need to upload the same image twice.

Just like copying the content from the original language, it is now also possible to duplicate the images and/or the featured image: enter image description here

share|improve this answer
    
Thanks for the answer Piet, i'm getting in touch with them to be sure i'd work fine cos this version i a for-sale one. Do you know if this "media module" you speak of is integrated within the whole plugin or is it an add-on to buy or get from them? –  kevin Jun 10 '11 at 15:21
    
@kevin, the media module is part of the paid version. They offer the paid version as 1 price for all deal, so no hidden fees and additional payments for extended functionality. –  Piet Jun 12 '11 at 4:37
    
Just got the paid version and so far i cant reach what i'm looking for. I see those checkboxes yes, but when i hit the translate button then the 'import content' button, it does import the content with the media, but not the featured image and the content of all the custom fields. However, when i hit'publish', the feat image does show up. Gona try to get in touch with the support to see if this has any chance to work or not. Thanks for help! –  kevin Jun 14 '11 at 1:07
    
@kevin you'll need to go into the media settings (of WPML) and process the images first. –  Piet Jun 14 '11 at 1:46
    
yeah i tried that, the 'Scan and duplicate attachement' button. It gives me back a '0 attachments not processed' instead of 1 for example but when i get back to the post i still dont have the picture into the field. I also tried with another plugin instead of 'Custom field template': wordpress.org/extend/plugins/advanced-custom-fields. Pretty annoying, seems simple and complicated at the same time... –  kevin Jun 14 '11 at 2:11
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.