Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

All plugins I've tried makes the page go blank.

I tried so far:

  • Smart Archives Reloaded
  • Clean Archives Reloaded
  • Better Extended Live Archives

Thanks.

Tal

share|improve this question
2  
Can you give some examples of some that are causing the problems? –  Chris_O Sep 19 '10 at 7:04
    
Hi Chris - I updated with examples. –  Tal Galili Sep 19 '10 at 21:24
    
I will take a look. Maybe @scribu (Author of Smart Archives Reloaded) will see your question and add some insight. –  Chris_O Sep 20 '10 at 3:14
    
Thank you Chris. –  Tal Galili Sep 20 '10 at 10:25
add comment

2 Answers 2

up vote 1 down vote accepted

@Tag,

To answer your question directly, Smart Archives Reloaded works with W3 Total Cache. I have thoroughly tested it on my test bed and it works fine with W3 Total. I was even able to easily add the js to my minify settings.

Version 2.0 removed the caching from the plugin. Have you tried it with the latest version?

No more buggy caching

Older versions of the plugin stored the generated HTML in a text file, instead of generating it on each page load. Unfortunately, this relied on two rather unreliable things: file permissions and wp-cron. Thus, it was the biggest source of problems for users. So I decided to remove file caching completely.

If you want caching back, the best solution is to use a dedicated plugin, such as WP Super Cache. It will make your entire site load much faster.

It seems that some of the other archive plugins use some sort of caching mechanism which might cause a conflict with a dedicated caching plugin like W3 Total.

share|improve this answer
    
Hello Chris (thank you for the answer), I am using "SAR" (version 2.0.3_, and it only creates a blank page, see here: r-bloggers.com/archive –  Tal Galili Sep 20 '10 at 8:12
2  
The problem is not with either plugins. I think you have some issues with your theme. One big problem I see is an improperly declared Doctype and other Validation errors. Switch themes to 2010 and see if you have the same problem. –  Chris_O Sep 20 '10 at 10:26
    
Thank you Chris, I will look more into it. –  Tal Galili Sep 21 '10 at 13:03
add comment

W3 Total Cache just buffers and caches whole output, it has very little interaction with other plugins.

Does it work with W3 disabled?

Had you tried this with define('WP_DEBUG', true); in wp-config.php to see if there any error messages?

Common issue with archive plugins is that they run out of available memory.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.