Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I try to upload an image to a post, I get an error:

"The uploaded file could not be moved to /home/httpd/xxxx/xxxx/xxx/wp/wp-content/uploads."

My server is set up in safe_mode - is that the problem? What can I do about it?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It has nothing to do with safe_mode try this:

  • login to your ftp
  • make your wp-content folder 755
  • inside wp-content create a new folder called "uploads", make it 777 (755 should also work)
  • inside the control admin panel, go to settings>miscellaneous and on the first line enter "wp-content/uploads" as where your uploads will go to.

Save and go try !

share|improve this answer
    
I saw these instructions elsewhere online. Although they probably generally work, this does not work for me. The uploads folder is created already. –  GavinR Jun 9 '11 at 23:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.