Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have this issue, where I can't access the frontend without a blank page anymore. It drives me crazy.

The backend seems to be up just fine, but the frontend is white. When trying to chose another theme (twentyten) this one also returns white, already in the preview.

What can I possibly do?

Edit 1:

This is what I get

Notice: Constant TEMPLATEPATH already defined in /site.com/html/wp-includes/default-constants.php on line 278

Notice: Constant STYLESHEETPATH already defined in /site.com/html/wp-includes/default-constants.php on line 284

Warning: Cannot modify header information - headers already sent by (output started at /site.com/html/wp-includes/default-constants.php:278) in /site.com/html/wp-includes/pluggable.php on line 897

share|improve this question
    
What Plugins do you have active? –  Chip Bennett Jun 10 '11 at 17:05
    
At the moment I disabled all plugins! –  Simon Jun 11 '11 at 11:42
    
What Theme are you using? What version of WordPress are you using? Have you customized wp-config.php to define STYLESHEETPATH and/or TEMPLATEPATH? –  Chip Bennett Jun 11 '11 at 12:30
    
Thank you! I actually had STYLESHEETPATH and TEMPLATEPATH defined for additional speed in wp-config.php and have left it uncommented in this version of the backup. Thanks! –  Simon Jun 11 '11 at 13:29
add comment

2 Answers

If you have ftp access to your site, go to the root. There is a line in wp-config.cfg:

define('WP_DEBUG', false);

Switch it to:

define('WP_DEBUG', true);

Upon returning to one of the blank pages, you'll notice an error message which can shed some light on what is going wrong. From there you may either correct the issue, or bring that error back here and we can offer more help.

share|improve this answer
    
Thanks Drew! However I can't quite make sense of what these errors actually are saying. I'm going to need to post since there is not enough space here. –  Simon Jun 9 '11 at 12:10
add comment

Based on the comments above: check for custom define() calls for STYLESHEETPATH and TEMPLATEPATH in wp-config.php.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.