Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

alt text

I keep getting the same error, any ideas?

  1. I have generated a key without a password using ssh-keygen
  2. I set permissions on the keys to 600
  3. I have successfully logged in using ssh -i /root/.ssh/id_rsa 1**.**.*8.128
  4. I have tried changing hostname to localhost and 127.0.0.1

The server is running CentOS 5.4.

share|improve this question
1  
have you tried using localhost instead of the ip address? –  Chris_O Sep 18 '10 at 2:59

2 Answers 2

up vote 1 down vote accepted

This Question was answered on ServerFault by the asker. I am adding his answer here as a community wiki.

Here is the full solution, thanks to michaelmior for his help, it got me half way.

  1. Run this command to generate keys: ssh-keygen

    You'll get this output:

    Generating public/private rsa key pair.
    Enter file in which to save the key (/home/user1/.ssh/id_rsa):
    Created directory ‘/home/user1/.ssh’.
    Enter passphrase (empty for no passphrase): (just hit enter, no need for a password)
    Enter same passphrase again: (same thing, hit enter again)
    Your identification has been saved in /home/user1/.ssh/id_rsa.
    Your public key has been saved in /home/user1/.ssh/id_rsa.pub.
    The key fingerprint is:
    xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx user1@server1.example.com
    
  2. Add the public key to your authorized_keys file

  3. Move the id_rsa and id_rsa.pub to /usr/local

  4. chown the files to the same user as your webserver (in my case apache)

  5. chmod the files to 600: chmod 600 id_rsa*

This should now work.

However, my installation kept hanging, a quick look at the httpd error_log file show me:

PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 2966269 bytes) in /var/www/sites/....

Adding this code to the Wordpress wp-config.php file to temporally increase the amount of memory available:

define('WP_MEMORY_LIMIT', '64M');
share|improve this answer

also is php compiled with ssh support? most hosts don't come with the pecl ssh extension..

share|improve this answer
    
I think Wordpress only shows the SSH option if it's supported. –  rjstelling Sep 19 '10 at 11:22
    
ahh in that case, look in your server logs, /var/log/secure or /var/log/messages .. is php using the same key to login, as you think? –  Vid Luther Sep 19 '10 at 21:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.