Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

am running the CFT plugin version 1.9.2 on a 3.1.3 wordpress site and in the admin i did set up 30 input file fields related to a custom post type. It all works fine until the 21st field (and beyond) that does not save any file (small picture) that is selected.

I did a local test on wamp, and it all works fine, all the 30 fields are saving (and displaying) well the pictures.

I did another test online (different server) on a test installation. I uploaded the database used locally and all the files, checked the site and the post is displaying well the pictures: link and has obviously all 30 saved in the admin.

So after that i tried to create a new post on this test site and uploaded the pictures from the admin and bam there goes the same problem, stuck at 20: link.

The media upload works fine by the admin works fine, even with high res pics.

Here's the beginning of my template's content in the CFT admin:

[project-introduction]
type = textarea
label = Introdução
cols = 50
rows = 6

[p-img-1]
type = file
label = Imagem projeto #1 (capa)

[p-img-2]
type = file
label = Imagem projeto #2

[p-img-3]
type = file
label = Imagem projeto #3

I also tried to add the blank = true to my type= file fields but didnt seem to help.

I'd be glad to have your point of view on this cos am stuck. Thanks in advance.

share|improve this question
    
Seems like it's a php configuration setting "max_file_uploads" rather than a wp problem. Support says i gotta add " ini_set (max_file_upload, xxx )" at the beginning of my script. Question is, where is this script? And is there a way to add this within the functions.php theme file? –  kevin Jun 9 '11 at 14:06

2 Answers 2

up vote 0 down vote accepted

Update, just got the problem back and found a 'real solution, to update the php.ini file at the root of the site with this: max_file_uploads = 100

share|improve this answer

Found a solution. I divided my pictures into 3 templates and in the post admin i just have to load them with the drop-down menu. The value of "max_file_uploads" is still stuck at 20 but for now it's the best solution i found.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.