Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

We have just updated to WordPress 3.1.3 by following the WP manual install tutorial. Note: This is a Network-enabled (multi-site) install. After uploading the new files, we now get the following error for ALL pages in the blog:

Error 101 (net::ERR_CONNECTION_RESET): Unknown error.

Any ideas? Here are the examples of our logs when the error occurs, and some of the WP-important files:

error_log

[Tue Jun 07 15:40:01 2011] [error] [client 10.10.0.3] PHP Warning:  require(/var/www/html/root/wordpress/wp-includes/load.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /var/www/html/root/wordpress/wp-settings.php on line 19
[Tue Jun 07 15:40:01 2011] [error] [client 10.10.0.3] PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required '/var/www/html/root/wordpress/wp-includes/load.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/root/wordpress/wp-settings.php on line 19
[Tue Jun 07 15:40:01 2011] [error] [client 10.10.0.4] PHP Warning:  require(/var/www/html/root/wordpress/wp-includes/load.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /var/www/html/root/wordpress/wp-settings.php on line 19
[Tue Jun 07 15:40:01 2011] [error] [client 10.10.0.4] PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required '/var/www/html/root/wordpress/wp-includes/load.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/root/wordpress/wp-settings.php on line 19

wp-config.php

define('WP_HOME','http://www.mysite.com');
define('WP_SITEURL','http://www.mysite.com');

define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
$base = '/';
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

.htaccces file (in wordpress root directory)

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
share|improve this question
add comment

2 Answers

Are you sure /wp-includes/load.php made it to the server? If you were installing manually, there's a chance it got lost during the transfer. Happens to me occasionally using FileZilla.

The error messages are basically telling you that the server can't find the file, so make sure the file is there.

share|improve this answer
    
Thanks for the comment - sorry, we can confirm that the load.php file is there. On previous attempts to update, we've also seen this error complain about not finding /wp-includes/wp-class.php instead of load.php. Doesn't seem consistant on which file it errors out on. –  Alex Jun 8 '11 at 14:53
add comment
failed to open stream: No such file or directory

1) Did you reupload wp-admin and wp-includes?

2) If it's a VPS, reboot.

share|improve this answer
    
Thanks - yes we reuploaded wp-admin, wp-includes, and the ancillary files in the root (and a few in wp-content) just like the instructions say. We will look into the reboot... –  Alex Jun 8 '11 at 14:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.