Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Added a subcategory to WordPress. Wrote a blog post and attached it to this subcategory. Now for some reason when I check it on my site, it give me the below error:

Sorry, you are looking for something that isn't here.

The weird thing is that I can still access the post from the front page, and it shows me the correct URL:

subdomain.domain.com/category/subcategory/postname  

But when i remove "postname", it says it can't find it.

Any ideas?

share|improve this question
    
As it was showing on the frontpage, I tried adding the frontpage code to a custom category page, but this didn't work either... . –  WouterB Jun 5 '11 at 18:41
    
can you accesss the new subcategory from the category menu or from a category widget? what is the permalink that shows in these cases? i assume it should be: subdomain.domain.com/category/maincategory/subcategory –  Michael Jun 5 '11 at 18:51

1 Answer 1

so your permalinks are /%category%/%postname%, are you using a plugin to remove the category base? typically path to the category page would be

subdomain.domain.com/category/*categoryname*/*subcategoryname*/
share|improve this answer
    
Thanks for the quick reply Milo. Meanwhile, I found a solution. I did indeed remove the category base from the permalinks and adding .html to it fixed the problem. I've also quickly described it in more detail here: tech.wouterbertels.be/wordpress/category-page-shows-no-posts. –  WouterB Jun 5 '11 at 19:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.