Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I disabled the posts revision feature according to this codex by placing this code in the wp-config.php:

define('WP_POST_REVISIONS', false );

But revions are still being saved by the WP. Why?

I am using wp3.1.3 and Twenty Ten theme. I have couple of plugins, and disabling them does not resolve the issue.

share|improve this question
    
so when you add this code does it still show the post revisions in the edit post single page view? If so this is because there are already revisions present. This will only activate on new posts. You can always go into your db and manually delete the revisions –  xLRDxREVENGEx Jun 4 '11 at 6:55
1  
no this goes into your wp-config.php file –  xLRDxREVENGEx Jun 4 '11 at 21:12
1  
In the root of your wordpress directory is the wp-config.php file this is where it goes not your functions.php and your post above says wp-config.php –  xLRDxREVENGEx Jun 4 '11 at 21:14
1  
Sounds good. since i did not really answer the question can you give me an up vote on the solution at lease. –  xLRDxREVENGEx Jun 5 '11 at 4:32
1  
@xLRDxREVENGEx, I be glad to, but I don't know how to go about doing it. I don't quite understand many features of this website yet. –  Tara Jun 5 '11 at 18:06
show 9 more comments

2 Answers 2

up vote 0 down vote accepted

wp-config.php is suggested place for such definitions, because at any point later they might get replaced by default values during loading.

See Editing wp-config.php in Codex for thorough instructions.

Also worth noting that it's commonly said like add to the end, but really definitions should go above this line:

/* That's all, stop editing! Happy blogging. */

Or, if it was removed for some reason, above:

require_once(ABSPATH . 'wp-settings.php');
share|improve this answer
add comment

Try using this instead define('WP_POST_REVISIONS', 0);
I am currently using this on my wp-config.php file and it is working on my blog. (:

share|improve this answer
    
thanks for the reply. I tried your suggestion, unfortunately it did not work for me. –  Tara Jun 4 '11 at 3:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.