Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've just installed a fresh WordPress setup on Windows Server 2008 Web R2 (IIS7) with SQL Server Express and WordPress 3.1.

I completed the install successfully and logged into the admin section to start the activation of the WordPress network (using sub-domains). Having edited the wp-config file, I added the code WordPress generated to both wp-config (Network specific) and web.config (Rewrites).

Since adding these changes, each time I try to login to WordPress, I just get loop'd straight back to the login page. I've tried to following so far:

  1. Comment out the network specific changes in wp-config and revert the rewrite rules to standard WordPress ones (Didn't work).
  2. Checked IIS Admin for any re-writes already in place (None)

Details of wp-config and web.config below:

wp-config:
define('WP_ALLOW_MULTISITE', true);

define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', true );
$base = '/';
define( 'DOMAIN_CURRENT_SITE', 'svr-web-csrms' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

web.config: http://pastebin.com/8xctXizE

Update: I have had a thought. From reading this here:

Note that per the Settings Requirements you cannot switch from Sub-folder to Sub-domain >when running on 127.0.0.1 or localhost. This can potentially cause an endless loop of >reauth=1 on your root site due to cookie handling.

I may have an issue due to the fact I am using an internal address. I'll set WordPress up with a proper domain and come back.

share|improve this question
    
Any progress? Could you resolve the issue? If so, please add your solution as answer and mark the question as answered. –  toscho Feb 16 '12 at 22:03
add comment

1 Answer

up vote 1 down vote accepted

This sounds like your domain doesn't match the cookie being generated. It may not have anything to do with the IP.

define( 'DOMAIN_CURRENT_SITE', 'svr-web-csrms' );

I would expect an actual domain or something, like this.

define( 'DOMAIN_CURRENT_SITE', 'subdomain.mysite.tld' );

I tried to look at your web.config - but it appears that the URL is now broken.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.