Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My new site was initially set up with an IP address (say http://123.123.12.12/). I later changed the siteurl and homeurl to my domain (say xyz.com). I also pointed the domain to the IP address so I don't lose out on the indexing in search engines.

But now whenever I click on any of the links in the home page, it redirects back to http://123.123.12.12/ instead of going to http://123.123.12.12/newpage/

The anchor tag shows the URL as http://xyz.com/newpage/

Any relative URLs on any other pages work fine. But otherwise all links (from the menu) redirect to the home page.

To summarize, any urls saying http://xyz.com/somepage redirect to home page

Any ideas what I might be missing?

Thanks.

P.S. I changed the siteurl and homeurl in the database directly. Do I need to change it on the Wordpress Settings page as well?

share|improve this question
    
You should have changed this in your WordPress settings. If you manually changed it in the database your Settings should reflect the changes you made. Would you please check that they are correct? It would be helpful if you could let us know what you changed in the database and how you did this. –  Elpie May 30 '11 at 7:35
    
they showed up correctly there. My guess - since this was a multisite install, the change didn't happen properly (still not sure why) –  lostInTransit May 31 '11 at 7:33

1 Answer 1

up vote 1 down vote accepted

Clear your permalinks by going to the permalinks page usually all it takes it just visiting it. Also clear your cache and flush your dns settings. Also make sure to clear any WordPress plugins that use cache. Check those and report back

share|improve this answer
    
Can't "save" the permalinks from the Settings page. It is a multisite installation and I removed the "blog" slug. If I save from the permalinks page, the slug will get added again! Clear cache - checked. Flush DNS settings-done. None of the plugins I have use cache. –  lostInTransit May 30 '11 at 4:58
    
what kind of multi-site install? And no you do not need to change it in the settings page. Try doing a search in your db for the old url you where using and change it to the new one. As well check the .htaccess file. –  xLRDxREVENGEx May 30 '11 at 5:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.