Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I just installed a WPML, but my custom post types is showing just in default language, if I am switching to other languages, it will show the same posts as default language, but in wordpress panel they are translated.

Part of my code in function.php

$args = array( 
        'labels' => $labels,
        'public' => true,
        'publicly_queryable' => false,
        'show_ui' => true,
        'query_var' => true,
        'rewrite' => true,
        'capability_type' => 'post',
        'hierarchical' => true,
        'menu_position' => 5,
        'supports' => array('title','thumbnail','taxonomy')

And to get those post types I am using :

query_posts('post_type=objekts');
...
share|improve this question

3 Answers 3

up vote 2 down vote accepted

Which versions of WPML and WordPress are you using? I'm sure that you noticed that the old versions of WPML from wp.org only run on old WordPress versions (up to 3.0.5).

share|improve this answer

Did you activate WPML support for your custom post type?

  • WPML > Translation Options

You should see a list of custom post types and you can set them to allow translation.

share|improve this answer
    
Sure. Already did that (dl.dropbox.com/u/8228019/custom.PNG), it just isnt reacting when I am switching languages in front-end, in back-end panel i assume everything is fine. Maybe I need to change some code? Or maybe I have to buy the newest version of plugin? –  Kaspars May 26 '11 at 11:28

Be sure that you have 'has_archive' => true in your post-type declaration.

share|improve this answer
    
Why would this be a solution? –  kaiser Nov 4 '12 at 22:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.