Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have featured images switched on in my theme:

add_theme_support('post-thumbnails');
set_post_thumbnail_size(256,128, true);
add_image_size('icon', 128, 128, true);

but the Featured Image box isn't showing up anywhere when I edit a page. What's confusing is that the exact same theme, the same set of plugins and approximately the same data is working fine on another site. Is there some config setting that might prevent the Featured Image feature from working?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Have you checked the "Featured Image" check-box within the "Screen Options" drop down menu beneath "Howdy, your username"? If that's not the case, we can look into it even further.

Update: WordPress MU users: Try going into "Network Admin", then click on settings, then enable image upload box, and save.

share|improve this answer
    
I checked, and the option for Featured Image isn't there on the Screen Options. It clearly doesn't think the theme has support - but I've established with judicious use of die() that the lines in my functions.php are being run. –  Marcus Downing May 24 '11 at 8:21
    
Alright. Are using the latest version of WordPress? Try switching to the latest version of the twentyten theme for a brief moment to confirm that the Featured Image check-box is showing up or not. –  VicePrez May 24 '11 at 8:37
    
I've established that both post_type_supports('page', 'thumbnail') and current_theme_supports('post-thumbnails', 'page') are true on the edit form page. That leaves multisite as the culprit - something to do with "media buttons"? –  Marcus Downing May 24 '11 at 8:39
    
The media buttons - little icons above the content that add images etc - are indeed missing. So it doesn't believe there are any valid media types that could be used for a featured image. –  Marcus Downing May 24 '11 at 8:43
1  
If thats the case try going into "Network Admin", then click on settings, then enable image upload box. –  VicePrez May 24 '11 at 8:45

For anyone on Wordpress 3.2.1 & Up — The Featured Image option has moved into the Media Uploader. When you add an image, it shows up as an option under each individual image to set it as a the featured image.

share|improve this answer

protected by toscho Jun 20 '12 at 7:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.