Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I uploaded the "uploads" folder to my wordpress install manually from a backup with the exact domain. All of the media properties for height and with are the same and they are all visible on the site. The only problem is that I can't see them in the media tab. Any fix for this?

share|improve this question
add comment

2 Answers

First, its not a bug. Its by design. Second, you can try this plugin - http://wordpress.org/extend/plugins/add-from-server/

share|improve this answer
add comment

Unless I am mistaken, when you upload a file in Wordpress, it actually places the file in the uploads folder, but also adds a post entry to the database behind the scenes somewhere. If you are missing that MySQL data for Wordpress to know what to show in the Media Gallery, then they won't show up in that view (even though the files are technically there behind the scenes).

Also, you may want to double check your path in Wordpress for the folder just in case. You can find this at Settings-->Misc

share|improve this answer
    
the media library adds a post entry with an attachment type and list the link to it but it can be a pain to manually create this entry for every image and sometimes rarely works. Like mentioned below your better of using a plugin wordpress.org/extend/plugins/add-from-server –  xLRDxREVENGEx May 23 '11 at 23:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.