Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed a new WP site on local machine with wamp server. When a new user registers it gets the "registration successful" message but a mail with the password is never sent. Also checked the junk folder.
What can be the cause?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Probably your local setup since Wamp does NOT come with mail server. But you can configure the STMP settings of PHP to point to another server in your LAN which runs an SMTP server, or to the SMTP server of your ISP.

this thread has an example of how to set it up: http://www.wampserver.com/phorum/read.php?2,31302,70969

share|improve this answer
    
@Bainternet , after configuring the mail server do I need to configure anything on the wordpress installation? –  Ash May 23 '11 at 8:52
    
Nope just configure the mail settings and you are done. –  Bainternet May 23 '11 at 9:19
    
Great, thanks.. –  Ash May 23 '11 at 9:28
    
@Bainternet , I don't know how but the SMTP value in php.ini of the wamp server is already set to be my ISP's smtp server and the port is 25. Still, the mails from wordpress are not arriving. –  Ash May 23 '11 at 9:53
1  
@Bainternet , I still get the same message. But I managed with the 'WP-Mail-SMTP' plugin. Only instead of sending through the ISP I used my online websites host. Thanks for your help. –  Ash May 25 '11 at 12:01

Chances are that this isn't really a WordPress issue, but actually an problem with how you're setup for mail on your local machine / dev environment.

You can install a 'dummy' SMTP server on your local dev machine that allows you some independence from your environment. I often work at client sites where access to port 25 is tightly controlled, and using MockSMTP is very helpful for testing notification emails

For OS X: MockSMTP

For Windows: smtp4dev

share|improve this answer
    
Thank you, anu. –  Ash May 23 '11 at 9:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.