Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am currently running WordPress 3.1.2 on PHP 5.1.6. The minimum requirement for WordPress 3.2 is going to be PHP 5.2.4 or greater. If I keep running WordPress 3.1.2 and there is a security issue will they provide security updates for 3.1 or will I be forced to upgrade my version of PHP so that I can upgrade to WordPress 3.2?

share|improve this question
add comment

3 Answers

up vote 7 down vote accepted

WordPress backports security updates usually 1-3 versions back but they don't promise anything.

The WordPress LTS philosophy is that LTS = "Long Term Suckage"

The Long Term Suckage theory is:

While I like the theory of LTS, what happens in practice is it covers up the incompetence of IT or developers because they put off small slightly painful upgrades until they get so out of date of trunk (3 years? 5 years?) and you have to go through a giant, painful, screws everybody over upgrade. --Matt Mullenweg

Like how your sysadmin doesn't want to update PHP now that it's 6 years old and 2 major branches behind.

I would point my sysadmin to this thread from the RedHat mailing list from 2009. There are 3rd party packages available so you don't have to compile from source

If the version of php you need is not available in rhn you could use some 3rd party repos like rpmforge, ATrpms or the Remi Collet Repository that is specially made for mysql 5.1 and php5.2.9 under EL5.

I would be more concerned about PHP 5.1 branch security issues than something that might come up with WordPress.

Edit:

Also found this official RedHat announcement from Jan 2011 RHEL 5 now shipping with PHP 5.3.

share|improve this answer
add comment

No, older versions are not updated.

Aside: PHP 5.1.6 is five years old. Even if WordPress would offer patches for 3.1.2 – you missed more than 100 security fixes for PHP, so WordPress isn’t your main problem anyway.

share|improve this answer
    
I am running RedHat Enterprise Linux and up to until recently the official packages only provided PHP 5.1.6. Luckily as of RHEL 5.6 they now provide PHP 5.3 packages. I know I could have compiled PHP from source but my system administrator did not want to do that. As far as security goes I believe RedHat incorporates all security fixes into their packages. –  ejunker May 20 '11 at 16:55
    
@ejunker I’m well aware of the logistical problems for PHP updates. But in the last weeks a lot of backwards compatible code has been removed from WordPress. New patches may be not compatible with older versions, so they have to be written and tested twice – and released later. This would be bad for everyone. –  toscho May 20 '11 at 17:05
    
As php is not developed by redhat there is really no chance that there have been security fixes and php is now a whole new sub-version things have changed it is best to update to the latest php as hackers look for exploits and will use them to there best –  xLRDxREVENGEx May 20 '11 at 17:08
    
FYI, WordPress 3.2 is dropping support for anything less than PHP 5.2.x and MySQL 5 –  calvinf May 21 '11 at 0:15
add comment

WordPress does not patch older versions, so you will have to upgrade or manually apply patches yourself.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.