Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I added a page to my site, and suddenly the home page seems to be redirecting to that page (that is, if you go to jesseliberty.com, which should bring you to the home page, you are redirected to jesseliberty.com/newPage (the page I created).

To combat this, I've added a 301 redirect from jesseliberty.com/foo to jesseliberty.com/2010 which shows all the posts from this year, but is not, by any means, the right thing, and will truly fail in January.

Any ideas on what caused this or what I can do about it? There is nothing obvious in .htaccess

share|improve this question
    
I am unable to reproduce your problem. It looks like you solved your issue. –  hakre Oct 14 '10 at 18:36
add comment

4 Answers 4

Your home page response is 301 redirect to /categories/, no ideas what is causing it for now (.htaccess? WP?).

Had you tried to simply un-publish page that is (supposedly) caused this?

share|improve this answer
add comment

Weird. I am having the same issue. I'm at kellycain.com and my wordpress now redirects to kellycain.com I tried deleting the page, and then when I re-added the page, it redirected me to kellycain.com/photog-2. any ideas?

share|improve this answer
add comment

I think I've had this problem before, but I can't remember exactly how I fixed it. Check a few things:

  1. Did you recently or ever make a template/theme file called home.php? That can mess up wordpress because it thinks home means blog home not what you're thinking of as home. If you need a template for your home page you should call it homePage.php or homeTemplate.php etc.

  2. In your dashboard check in Settings > Reading and look if you're set to "static page" that the correct pages are set as home page and posts page.

  3. Check that your .htaccess file is writable and that the following is in it, also try turning off permalinks and see if that's the problem:

    RewriteEngine On RewriteBase / RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

  4. And last but not least, uninstall plugins and check if that fixes it.

share|improve this answer
add comment

Kelly, your page is still present in the trash bin within the page admin area. Remove it from there too and you should be fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.