Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have noticed that when I am in my Dashboard and switching from main Dashboard to for example plugins, Twitter seems to be loading something.

As I am located in China where Twitter is blocked, it always takes forever for my browser to realise that Twitter cannot be loaded, and thus before the page(s) finish loading.

This screenshot is for going to the plugins page, but it happens everywhere in the Dashboard.

Browser at plugin page loading something from platform.twitter.com

Is this normal? And can it be blocked/removed/undone?

share|improve this question
    
The default dashboard widgets from WordPress doesn't query twitter in any way. This must come from a custom plugin you're using. Maybe you can post a list of all active plugins here? –  rofflox May 19 '11 at 8:15
    
I can assure you that it has nothing to do with any of my plugins, but for the sake of this discussion the list of my network activated plugins is: Easy FancyBox, Gravity Forms, Multisite Dashboard Feed Widget, Widget Logic, WordPress Database Backup, all 5 WPML modules, WP Status Dashboard. The plugin that is not network activated, but activated on this site in particular is: WP-PostRatings –  Piet May 19 '11 at 8:49
1  
As a temporary remedy you could setup a host file on your computer with Twitter to 12.0.0.1, at least then it would 404 instantly instead of timeout. –  Dunhamzzz May 19 '11 at 9:20
1  
@Piet: If you're on Linux/Mac: Edit the file /etc/hosts and add a new line. E.g. 127.0.0.1 platform.twitter.com. If you're on Windows, the file is located under c:\windows\system32\drivers\etc`. You may also need to flush your local dns cache. This is only a quick&dirty fix. Every request which would go to platform.twitter.com is redirected to your local system. Therefore, you should try anus suggestions to find out what the real problem is. –  rofflox May 19 '11 at 10:19
1  
@Piet: The hosts file is a file on your computer where you can specify the IP addresses of specific domains, overriding normal DNS lookups. This blog post explains how to edit it on a Mac. If you add a line with 127.0.0.1 platform.twitter.com, all requests for that domain will loopback to your own computer, and thus give a quick error instead of a long timeout. You can remove the line later when you no longer need it. –  Jan Fabry May 19 '11 at 10:22

3 Answers 3

  • What happens when you try it with all your plugins disabled?

  • What happens when you try is with the default WP theme?

  • What happens when you try it with a different browser that has no browser extensions or add-ins installed?

  • What happens when you set twitter.com -> 127.0.0.1 as suggested?

share|improve this answer
    
the problem only manifests itself in network admin of a multisite install. When all plugins are disabled the same thing happens, haven't tried disabling all themes, because although it is a sandbox site, the main site is stil live. I don't have another browser without any extensions installed and the suggestion twitter -> 127.0.0.1 works brilliant –  Piet May 19 '11 at 10:38
up vote 0 down vote accepted

problem not resolved, temporary solution is to add a host entry for the twitter host to point it to localhost as offered by @Dunhamzzz and explained further by @Roman and @Jan

share|improve this answer

Piet,

I had the same situation (I am in Beijing) and just now figured out the solution that works for me.

I am using a premium theme from Themolution and they included their own dashboard framework, and found out it includes a direct twitter widget connection linked to follow their twitter acount...

I tried hard coding the dashboard widgets away (also possible via WP Total Hacks plugin), but in the end the Twitter Update widget still stayed available, and it wasnt a plugin I installed, so I checked the html output which indicated that something wanted to follow themolution's twitter. Inside their "theme-dashboard.php" they link to a twitter plugin they included in their "../themolution/assets/includes/widgets" folder.

I edited the theme-dashboard.php and now everything loads like a charm. Keep in mind for me it was only loading twitter on the actual dashboard page, NOT on the plugin page and others..

Hope this helps a bit.

cheers bas

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.