Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've got an issue with using the WP-Navi plugin and posts sorted alphabetically. The first page of posts (5 - set in the plugin settings) appearing properly, but when one navigates to subsequent pages, I lose that sort. In fact, I can't tell how the posts are being sorted - it appears to be random.

The plugin's author has a description of this problem, but says that it's fixed in the plugin version that I have and I can't figure out where in the plugin code to verify. Should I abandon the plugin and try to code into the template or functions file?

Can anyone help?

share|improve this question
    
Add a link to the plugin. There are so many similar named plugins – we cannot know which one you use. –  toscho May 16 '11 at 20:11
    
Thank you! Here is the link to the plugin: webdevstudios.com/plugin/custom-post-type-ui –  mktggirl May 17 '11 at 2:34
    
That’s not a WP-Navi plugin, is it? Now I’m confused. –  toscho May 17 '11 at 10:21
    
Thank you for trying to help me with this one. I'm sorry that I had provided the incorrect link - way too tired at that point. I eventually figured it out on my own and then had trouble getting back into this site to acknowledge your effort on my behalf. All is good now - thanks again~ –  mktggirl Jun 6 '11 at 14:24
    
Please add your solution as an answer and mark it as answer. –  toscho Jun 6 '11 at 14:27
add comment

1 Answer

up vote 0 down vote accepted

Switching to a new navigation plugin solved this problem!

http://wordpress.org/extend/plugins/wp-paginate/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.