Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I see that you solved the problem of a WordPress user memo-maritime two years ago "Same posts from my homepage is on all of my different pages".The same problem i have.What should I do?I installed Pagenavi but not working.Theme by default(default.php) is something like this:

<?php endwhile; ?>

<div class="fix" style="height:20px"></div>

<p class="ar hl3"><a href="<?php echo get_option('woo_archives'); ?>" class="more"><?php _e('SEE MORE ARTICLES IN THE ARCHIVE',woothemes); ?></a></p>

</div><!--/box-->

Now I installed pagenavi and I modified it in blog.php:

<?php endwhile; ?>  

<div class="fix"></div>

<?php wp_pagenavi(); ?>

and in default.php I left as I mentioned above, nothing happens anyway, I tried.Contrary send me the exactly same page that is repeated on all 3 pages.I tried to fixed many times, but nothing happens,the same..I do not know exactly where would be this issue, maybe it is not there.If I change the theme,works!So the problem is the current theme..this function is repeated somewhere

Many Thanks in advance

share|improve this question
    
please post the name of your theme. –  Michael May 14 '11 at 9:15
    
Premiumnews theme by woothemes.It's free theme –  Cyvic May 14 '11 at 9:21

1 Answer 1

try to do the following in /layouts/default.php (and /layouts/blog.php):

  • change the query line (line 5) to:

    wp_reset_query(); $paged = (get_query_var('paged')) ? get_query_var('paged') : (get_query_var('page') ? get_query_var('page') : 1 );
    $the_query = new WP_Query('cat=-'. $GLOBALS[ex_feat] . ',-' . $GLOBALS[ex_vid] . '&showposts=' . get_option('woo_other_entries') . '&orderby=post_date&order=desc&paged=' . $paged);

  • also add wp_reset_query(); before the line with wp_pagenavi();

make backup copies before editing.

share|improve this answer
    
Many thanks!! you are the man! one thing ,if you put the code wp_reset_query();before the line with wp_pagenavi(); is visible on the page, so I deleted it and works.!I tired three days,finally done it!with your help i fixed,thanks again –  Cyvic May 14 '11 at 11:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.